Lister sluggishness and failing to load

Incident Report for Lister

Resolved

We observed an unexpected increase in timeouts on our servers, which has now been resolved.
Note: The price prediction feature has been temporarily disabled to ensure continued performance.

Please reach out to support@uprightlabs.com or use the chat function to reach out if you have any questions. Thanks for your patience!
Posted May 12, 2025 - 16:59 UTC

Monitoring

Performance has improved. We are continuing to monitor for any further issues.
Posted May 12, 2025 - 16:44 UTC

Investigating

We are currently investigating reports of slowness and failing to load on Lister.
Posted May 12, 2025 - 16:09 UTC
This incident affected: Lister and Link.