Retrieving FedEx rates have appeared more stable in the past few hours. If you're still experiencing issues getting rates, please try refreshing the Shipping page and trying again or reach out to our Support team.
Posted Nov 27, 2023 - 20:58 UTC
Update
We're still seeing very occasional issues retrieving FedEx rates. If you're still encountering issues, please refresh the shipping page to try fetching rates again.
Posted Nov 27, 2023 - 18:41 UTC
Update
EasyPost has indicated issues with UPS Mail Innovations have been resolved. You may still experience errors fetching FedEx rates.
Posted Nov 27, 2023 - 17:17 UTC
Monitoring
These services continue to experience intermittent issues retrieving rates.
Posted Nov 27, 2023 - 17:04 UTC
Identified
FedEx and UPS Mail Innovations are currently experiencing some issues retrieving shipping rates. You may experience intermittent issues when using these two services. We're monitoring the situation and will provide updates as we know more.