FedEx carrier API performance has returned to normal. If you have any additional questions, please reach out to our support team.
Posted Jan 29, 2026 - 18:00 UTC
Update
EasyPost has reported that this is an identified issue involving reduced performance and increased timeouts and error responses from the FedEx API. EasyPost has contacted FedEx and they are working directly with FedEx to resolve the issue.
This FedEx-side issue is still impacting our ability to retrieve rates for some shipments. Our team continues to monitor the situation closely and will provide updates as we receive them.
Our support team is available if you have additional questions.
Posted Jan 29, 2026 - 15:59 UTC
Monitoring
The FedEx API is currently experiencing an increased error rate, as reflected on the EasyPost status page: https://www.easypoststatus.com/.
This may impact rate retrieval for some shipments.
Our team is monitoring the situation closely. Retrying your shipments in about 30 minutes may allow time for the issue to be resolved. Our support team is available if you have additional questions.