If you continue to experience issues loading rates, please refresh the Shipping page to try loading them again, or reach out to our Support team. Thank you!
Posted Mar 19, 2025 - 20:21 UTC
Update
The FedEx API error rate has normalized. We are continuing to monitor the EasyPost status page for additional updates.
Posted Mar 19, 2025 - 19:20 UTC
Monitoring
EasyPost has updated their status page with the following:
Monitoring - The FedEx API is experiencing elevated rates of errors and request timeouts for rating. FedEx has been notified and our engineers will continue to monitor the performance of the API.
Message from FedEx: We are experiencing an issue that started around 12:12pm CT today that is causing certain functions to operate slower than usual or be temporarily unavailable. Our IT teams are working diligently to identify and resolve the problem. We regret any inconvenience this have caused.
Posted Mar 19, 2025 - 18:18 UTC
Investigating
We are currently monitoring reports of increased error rates with the FedEx API beginning around 1:40 pm Eastern.
Posted Mar 19, 2025 - 17:56 UTC
This incident affected: EasyPost API and FedEx API.