Degraded performance with Upright Link and Lister

Incident Report for Lister

Resolved

Our third-party infrastructure provider has indicated a fix has been implemented, services have recovered, and the incident has been resolved.

If you continue to experience issues loading pages, signing into Link, posting, scanning, or others, please refresh your browser.

If you encounter any other issues, please contact our support team.
Posted Jul 10, 2026 - 18:02 UTC

Identified

We are currently experiencing a partial service degradation affecting but not limited to loading pages, signing into the Link application, posting, and scanning, related to an outage with a third-party infrastructure provider.

Their team is actively working on a fix, and our developers are monitoring. We will continue to provide updates as information becomes available.
Posted Jul 10, 2026 - 17:09 UTC
This incident affected: Lister and Link.