This incident has been resolved. If you continue to experience issues with Lister or Link, please reach out to our support team for assistance.
Posted Oct 21, 2025 - 11:01 UTC
Update
Amazon Web Services (AWS) is continuing to recover from earlier service outages which impacted our platform. While platform performance has improved, some clients may still experience intermittent slowness or degraded functionality in Link, Lister, and related third-party services.
We’re actively monitoring the situation and will continue to post updates on our status page (https://status.uprightlabs.com/) as recovery progresses.
For AWS’s latest updates, you can visit their Service Health Dashboard at ttps://health.aws.amazon.com/health/status.
Thank you for your patience.
Posted Oct 20, 2025 - 21:51 UTC
Update
AWS is continuing to recover from earlier service outages. While performance has improved, some clients may still experience intermittent slowness or degraded functionality in Link, Lister, and related third-party services.
We will continue to monitor the situation and will post additional updates as recovery progresses. Thank you for your patience as AWS continues to resolve this.
Posted Oct 20, 2025 - 19:54 UTC
Update
The global Amazon Web Services (AWS) outage that may cause intermittent issues with logging in or accessing parts of our platform. Our team is closely monitoring the situation and will share updates as they become available.
Thank you for your patience as AWS works to resolve this.
Posted Oct 20, 2025 - 16:56 UTC
Monitoring
Our cloud provider is currently experiencing service outages that may cause intermittent disruptions. As their recovery efforts continue, you may notice slowness or degraded performance in portions of Link and Lister.
This may also affect related third-party services, including email and chat support.
We are actively monitoring and will provide updates as more information becomes available.