Degraded SGW API Performance

Incident Report for Lister

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 11:53 UTC

Monitoring

ShopGoodwill API timeout frequency is beginning to improve, with stability and traffic starting to return to normal. We expect data from our platform to continue to sync with the Shopgoodwill marketplace. We will continue to monitor for impact and performance.
Posted Oct 29, 2025 - 23:38 UTC

Identified

Downstream effects of the ShopGoodwill API timeouts may be seen in other non-SGW functions in Lister, due to server load. We are mitigating and have heightened our server capacity to compensate. Most functions will be normal, however, some background jobs (image thumbnails and the like) may be delayed.
Posted Oct 29, 2025 - 16:35 UTC

Investigating

The ShopGoodwill API is experiencing timeout issues that will, in turn, affect listing and order fulfillment functionality in both Lister and the Seller Portal. The SGW development team is aware and working toward resolution. We will update this page once more information becomes available.
Posted Oct 29, 2025 - 16:14 UTC
This incident affected: Shopgoodwill API.