Issue impacting FedEx rates for Goodwill organizations

Incident Report for Lister

Resolved

This incident should now be resolved.
Posted Oct 03, 2025 - 17:06 UTC

Update

New information has been gathered by our partners to suggest that the rate issue affecting Goodwill organizations is with FedEx API.

Recommended Action - If you are experiencing this issue, please open a support ticket directly with FedEx. This can be done by signing into your FedEx account and following steps under "Support" in the menu, by reaching out to your account manager at FedEx, or by calling 1-800-463-3339 and press option 63 or say "Technical Support."

We continue to provide feedback and share customer-reported examples to assist third-parties in resolving the issue. We will monitor developments closely and share updates here as they become available.
Posted Oct 01, 2025 - 19:15 UTC

Monitoring

We are aware of a known issue impacting the EasyPost integration with FedEx.

Customer Action Required - If you are experiencing this issue, please open a support ticket directly with EasyPost by emailing support@easypost.com.

Ongoing Efforts - Our team is in active communication with EasyPost. We continue to provide feedback and share customer-reported examples to assist them in resolving the issue.

We will monitor developments closely and share updates here as they become available.
Posted Oct 01, 2025 - 14:59 UTC
This incident affected: FedEx API.