Slowness and failure to load

Incident Report for Lister

Resolved

This incident has been resolved, and you should see loading returned to normal.
Posted Mar 14, 2024 - 14:10 UTC

Monitoring

A fix has been implemented and we are beginning to see improvements. We are monitoring the results.
Posted Mar 14, 2024 - 13:45 UTC

Identified

We've identified the issue and are working on a possible fix.
Posted Mar 14, 2024 - 13:15 UTC

Investigating

Lister and Link are currently experiencing unexpected slowness and possible timeouts. Our team is investigating the situation and we will provide further information as we learn more.
Posted Mar 14, 2024 - 13:00 UTC
This incident affected: Lister and Link.