UPS API - Shipping Rate Errors

Incident Report for Lister

Resolved

The issue was identified on the EasyPost side connecting to UPS, and a fix was implemented. We are now seeing performance improvements retrieving rates on the Shipping page.
If you continue to experience issues loading rates, please refresh the Shipping page to try loading them again, or reach out to our Support team. Thank you!
Posted Jul 03, 2024 - 20:52 UTC

Monitoring

Customers with a UPS account linked to EasyPost may see errors fetching rates when creating shipping labels. We are continuing to monitor EasyPost's investigation into the UPS API experiencing high rates of errors and timeouts for rating, labels, and tracking. We will continue to monitor this and provide an update when it has been resolved.
Posted Jul 03, 2024 - 20:33 UTC

Identified

An issue has been identified with the UPS API experiencing high rates of errors and timeouts for rating, labels, and tracking.
We're monitoring the situation and will provide updates as they become available.
Posted Jul 03, 2024 - 19:42 UTC
This incident affected: EasyPost API.