Degraded Performance – FedEx API

Incident Report for Lister

Resolved

FedEx API performance has returned to normal. If you have any additional questions, please reach out to our support team.
Posted Jun 10, 2026 - 16:21 UTC

Monitoring

FedEx API performance has improved, and rate retrieval is returning to normal. We are continuing to monitor.
Posted Jun 10, 2026 - 16:06 UTC

Investigating

The FedEx API is currently experiencing an increased error rate, as reflected on the EasyPost status page: www.easypoststatus.com

This may impact rate retrieval for some shipments.

Our team is monitoring closely and will update as information becomes available. Retrying your shipments in about 30 minutes may allow time for the issue to be resolved. Our support team is available if you have additional questions.
Posted Jun 10, 2026 - 15:49 UTC
This incident affected: FedEx API.