FedEx error rates have dropped to normal levels. If you're still encountering issues, please try refreshing your page or reaching out to Support. Thank you!
Posted Aug 24, 2023 - 12:54 UTC
Monitoring
We're seeing FedEx rates start to re-appear in Lister and FedEx's API error rate percentage appears to be dropping. We're continuing to monitor the situation.
Posted Aug 24, 2023 - 12:46 UTC
Identified
FedEx's API is experiencing high rates of timeout errors which may lead to the inability to purchase FedEx shipping labels. We're monitoring and awaiting further communication from EasyPost on this outage.