EasyPost API - Label Purchasing Failing

Incident Report for Lister

Resolved

We've observed that the EasyPost API has been operating normally for the last 15 minutes. If you continue to experience issues, please reach out to support. Thank you!
Posted Feb 27, 2024 - 22:00 UTC

Update

EasyPost API failure rates have decreased. If you still encounter issues purchasing labels, please try to refresh the shipping page. We will continue to monitor.
Posted Feb 27, 2024 - 21:43 UTC

Update

EasyPost has indicated the problem has been identified and a fix has been implemented. We're continuing to monitor error rates.
Posted Feb 27, 2024 - 21:36 UTC

Monitoring

We continue to see high error rates with EasyPost's API. Rates will display, but purchasing of the label will fail. We're continuing to monitor for any updates from EasyPost.
Posted Feb 27, 2024 - 21:32 UTC

Identified

We're seeing increased reports of issues with EasyPost's API failing to purchase labels. We're monitoring the situation and will provide updates as we know more.
Posted Feb 27, 2024 - 21:25 UTC
This incident affected: EasyPost API.