FedEx API error rates have returned to normal and FedEx is reporting the status of this incident as resolved.
If you continue to experience issues returning FedEx rates, please reach out to our support team.
Posted Jun 26, 2026 - 19:51 UTC
Update
FedEx has confirmed the outage and has no ETA for full restoration at this time.
This may result in FedEx rates failing to load or intermittently load.
We will share additional updates as we receive them from EasyPost and FedEx.
Posted Jun 26, 2026 - 16:53 UTC
Identified
EasyPost has updated that they are experiencing reduced performance and increased timeouts/error responses from FedEx APIs, and have reached out to FedEx.
FedEx rates may fail to load or may intermittently load.
We will continue to provide updates as we receive them from EasyPost and FedEx.
Posted Jun 26, 2026 - 16:41 UTC
Investigating
We are receiving reports of rates from FedEx API intermittently failing to load, and clients having to refresh the shipment page to obtain rates.
This corresponds with an increased FedEx Error Rate on the EasyPost Status page (www.easypoststatus.com)
We are monitoring this, and will provide updates as we receive them from EasyPost and FedEx.