EasyPost incident, elevated error rate on USPS, UPS

Incident Report for Lister

Resolved

EasyPost has indicated that systems are operational and the incident has been resolved.
Posted Jun 05, 2026 - 15:24 UTC

Monitoring

EasyPost has reported that service has normalized.

If you still encounter issues purchasing labels, please try to refresh the shipping page. We will continue to monitor.
Posted Jun 05, 2026 - 15:10 UTC

Identified

We have confirmed an incident has been reported by EasyPost resulting in increased UPS and USPS error rates.

The service disruptions impact the ability to purchase shipping labels with these services.

We are monitoring, and will provide updates as more information becomes available.
Posted Jun 05, 2026 - 14:50 UTC
This incident affected: EasyPost API.