eBay Service Disruption

Incident Report for Lister

Resolved

eBay is still working through some lingering challenges, but performance has improved.

If you continue to have issues, please contact our support team.
Posted Apr 28, 2026 - 14:21 UTC

Monitoring

On April 26th around 3:30 PM, eBay experienced a significant platform outage, causing widespread disruption to API access and general site availability. The cause is attributed to eBay infrastructure.

Our developers are actively investigating potential double-sale scenarios resulting from the API disruption and cases are being handled as identified.

eBay performance remains slow, with edge-level errors being observed.
Posted Apr 27, 2026 - 16:29 UTC
This incident affected: eBay API.