System slowness and connectivity issues

Incident Report for Lister

Resolved

This incident has been resolved.
Posted Jun 18, 2026 - 17:50 UTC

Update

Lister and Link are fully operational, and the incident has been resolved. If you have any additional questions, please reach out to our support team.
Posted Jun 18, 2026 - 17:49 UTC

Monitoring

We have downgraded this incident's severity, as connectivity issues have reduced and slow loading of pages has improved. Our developers are continuing to monitor.

We will post additional updates as soon as we have more information.
Posted Jun 18, 2026 - 16:45 UTC

Update

Connectivity issues have stabilized and site timeouts are reduced. Our developers are continuing to work on the issue.

We will post additional updates as soon as we have more information.
Posted Jun 18, 2026 - 16:07 UTC

Identified

Our developers have identified that Lister is experiencing issues connecting with AWS.

This is resulting in site timeouts, and slow loading times on pages of Lister and the Link app. We are investigating, and we will share more details as soon as there is an update.
Posted Jun 18, 2026 - 15:12 UTC

Investigating

Our developers are currently investigating reports of system slowness and page timeouts loading pagers of Lister and Link.
Posted Jun 18, 2026 - 15:09 UTC
This incident affected: Lister and Link.