Slow Loading or Timeouts for Lister & Link

Incident Report for Lister

Resolved

Operations have returned to normal. We observed an unexpected increase in timeouts on our servers. Please reach out to support@uprightlabs.com our through the chat function if you have any questions. Thanks for your patience.
Posted Mar 24, 2025 - 17:51 UTC

Monitoring

Lister & Link should be responsive again. We're monitoring for any further issues.
Posted Mar 24, 2025 - 17:36 UTC

Investigating

We're aware Lister & Link may be slow to load or timeout when conducting normal operations. Our team is investigating the cause.
Posted Mar 24, 2025 - 17:27 UTC
This incident affected: Lister and Link.